Ferramentas do usuário

Ferramentas do site


infra-estrutura:cisco:aggregacao_rotas_bgp

Agregação de rotas com BGP

A agregação de rotas permite que não necessitamos anunciar todas as rotas individualmente, apenas anunciamos um rede que engloba todas as outras. Por exemplo digamos que tenho as redes a serem anunciadas:

  • 192.168.10.0/24
  • 192.168.20.0/24
  • 192.168.30.0/24
  • 192.168.40.0/24
  • 192.168.50.0/24

Ao invés de anunciarmos 5 vezes cara um das redes acima individualmente podemos fazer um único anúncio que pegamos todas as redes. O endereço sumarizado ou agregado para todas as redes acima seria 192.168.0.0/16. Esta rede vai de 192.168.0.0 até 192.168.255.255 onde as redes acimas estão dentro.

Ambiente proposto para teste

Este é o ambiente proposto temos 4 roteadores, cada um em um sistema autonomo. As rotas aprendias do AS 100 e 300 são anunciadas ao AS 400 pelo AS 200 com uma rota sumarizada ou agregada. Rotas anunciadas pelo AS 100 e 300:

  • 172.16.10.0/24 - AS 100
  • 172.16.20.0/24 - AS 300

Rota sumarizada para o AS 400.

  • 172.16.0.0/16

Os respectivos endereçõs das interfaces estão no desenho caso deseje replica-los. Vamos as configurações

Configurações roteadores

R1

hostname R1
! 
interface FastEthernet0/0
  ip address 192.168.1.2 255.255.255.0 
!  
interface loopback0
  ip address 172.16.10.1 255.255.255.0
!
router bgp 100 
  network 172.16.10.0 
  neighbor 192.168.1.1 remote-as 200 
!

R2

hostname R2
! 
interface FastEthernet0/0
  ip address 192.168.1.1 255.255.255.0 
!  
interface FastEthernet0/1
  ip address 160.20.1.1 255.255.0.0
!
interface FastEthernet1/0
  ip address 192.168.2.1 255.255.255.0
!
router bgp 200 
  neighbor 192.168.1.2 remote-as 100
  neighbor 192.168.2.2 remote-as 300 
  neighbor 192.168.3.2 remote-as 400
  aggregate-address 172.16.0.0 255.255.0.0 summary-only  
!
ip route 172.16.0.0 255.255.0.0 Null0
!

R3

hostname R3
! 
interface FastEthernet0/0
  ip address 192.168.2.2 255.255.255.0 
!  
interface loopback0
  ip address 172.16.20.1 255.255.255.0
!
router bgp 300 
  network 172.16.20.0 
  neighbor 192.168.2.1 remote-as 200 
!

R4

hostname R4
! 
interface FastEthernet0/0
  ip address 192.168.3.2 255.255.255.0 
!  
!
router bgp 300  
  neighbor 192.168.3.1 remote-as 200 
!

Testes

Abaixo temos as saídas dos comandos de visualização das rotas BGP anunciadas e recebidas.

Agregação com números de AS na rota

Para informar o número do AS na rotas utilizamos o comando as-set.

aggregate-address 172.16.0.0 255.255.0.0 summary-only as-set

Discussão

Insira seu comentário. Sintaxe wiki é permitida:
 
infra-estrutura/cisco/aggregacao_rotas_bgp.txt · Última modificação: 2019/03/26 23:19 por ricardobarbosams