Ferramentas do usuário

Ferramentas do site


infra-estrutura:cisco:configurando_nat_cisco

Configurar NAT nos roteadores Cisco

Com este tutorial quero deixar um guia rápido para configurar roteadores Cisco.

Definindo as interfaces inside e outside.

interface GigabitEthernet0/0
 ip nat outside

interface GigabitEthernet0/1
 ip nat inside

No exemplo acima omiti os endereços IP's de lan e wan para deixar a critério do ambiente.

Criando a regra de nat baseado na access list 100. Esta regra permite a tradução de endereços, ou seja, realizar o nat com o endereço ip aplicado a interface GigabitEthernet0/0.

ip nat inside source list 100 interface GigabitEthernet0/0 overload

A access-list mencionada na regra define quem fará uso do serviço de traduções. Vamos imaginar que a rede interna tem o seguinte endereçamento 192.168.1.0/24, então nossa access-list ficará da seguinte forma.

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

Desativando o NAT

Agora um script rápido para desativar o nat.

interface GigabitEthernet0/0
 no ip nat outside

interface GigabitEthernet0/1
 no ip nat inside

no ip nat inside source list 100 interface GigabitEthernet0/0 overload
no access-list 100

Configurando servidor DHCP

o serv Para tornar esse roteador Cisco o gateway da rede vamos configurar o serviço DHCP segue abaixo os comandos. O qual criará o escopo DHCP para rede 192.168.1.0/24 com gateway 192.168.1. e dns 8.8.8.8 com concessão de 9 dias.

Router(config)#service dhcp
Router(config)#ip dhcp pool POOL_REDE
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.1
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#domain-name cliente.ricardobarbosams.com.br
Router(dhcp-config)#lease 9

Criando exclusões DHCP

Abaixo criamos as exclusões do escopo dhcp para um range do endereço ip 192.168.1.1 até 192.168.1.5 e também para um único endereço IP 192.168.1.10

Router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.5
Router(config)#ip dhcp excluded-address 192.168.1.10 

Visualizando configurações DHCP

Comando para debug e análise das configurações DHCP criadas acima.

show ip dhcp binding 

Discussão

Insira seu comentário. Sintaxe wiki é permitida:
 
infra-estrutura/cisco/configurando_nat_cisco.txt · Última modificação: 2018/07/16 20:40 por ricardobarbosams